Select a different vehicle  
Recently Viewed
There are no recently viewed vehicles to display

Average Consumer Rating 130 Total Reviews
Write a review

Performance
Comfort
Value
Fun-to-Drive
Interior Design
Exterior Design
Build Quality
Reliability
2010 Altima Brake Failure
By Miss-taken on
Vehicle
2010 Nissan Altima 2.5 S 4dr Sedan (2.5L 4cyl CVT)
Review
Bought a 2010 Altima SL on 8-4-2010 and 6 weeks later it was in the shop for over a week for brake failure. Tech had no clue what was wrong. Had to call Nissan to diagnose. Turns out bad break booster in a brand new car! Everyone, including a mechanic says they wouldn't trust the car and I don't. This shouldn't have happened to a new car! Tried to trade, but the dealer I bought it from said it lost $6000.00 in equity in 3 months! Now I'm stuck paying on a car I'm terrified to drive. My bank feels horrible and approved me for a new loan, but because of the loss of equity, I can't get a new car to book and thats the requirement for the loan. Big price to pay for a driveway ornament.
Suggested Improvements
Inspect the brake system thoroughly before letting it off the assembly line.
Recommend (0) (0)
Report it
Comments (2) Post a Comment
By kriscamp
on 01/06/11 16:25 PM (PST)

I also have a 2010 Altima, with brake trouble, I bought the car in 12/09 and within 2 months of buying the car I started noticing that there was a problem with the brakes, they would squeel and then lock up very abruptly and the problem has only gotten worse. Been to the dealership multiple times for them to tell me there is no problem, even had the main guy from nissan come after I got a lawyer and it sounded great he said the things I told him reminded him of a few things that needed changed (brake booster and others) they kept my car for 2 days and didnt do a thing to it. Needless to say this will be the last Nissan I ever purchase.

Report it
By jo1989
on 03/29/12 08:49 AM (PDT)

I had the same problem with my nissan altima! brake boosters come with problems! my friend also had the same problem! but our cars were under warranty! so we took it to the dealer we bought them and had new ones installed! no charge since it was under warranty! 6 months after repair the car is doing magnificent!

Report it
Post a Comment

You must be signed in to post a comment.

Register

ADVERTISEMENT
Nearby Inventory Zip Code UPDATE
 
ADVERTISEMENT
ADVERTISEMENT
Have a question? We're here to help!
Chat*
Chat online with us
Email
Email us at help@edmunds.com
*Available daily 8AM-5PM Pacific