Select a different vehicle  
Recently Viewed
There are no recently viewed vehicles to display

Average Consumer Rating 78 Total Reviews
Write a review

Performance
Comfort
Value
Fun-to-Drive
Interior Design
Exterior Design
Build Quality
Reliability
9 of 9 people found this review helpful
Can't Be Trusted In The Heat of the Day
By smartsnacker on
Vehicle
2003 Ford Explorer Sport Trac XLT 4WD 4dr Crew Cab (4.0L 6cyl 5A)
Review
Over the past two years, my 2003 Ford Explorer Sport Trac seems to get vapor lock in the summer. But it doesn't happen all the time. When it happens, I'll take it into the dealer, but the service team can't duplicate the problem. What happens (sometimes) is that I'll drive it to the store (maybe 6 miles), turn it off and shop for maybe 10 minutes. When I return to the vehicle and start it, it will sometimes not start, or, if it starts, it won't let me go over 20 mph. I had the fuel pump replaced in March (it's now June) and that seemed to help. But the other day, out of the blue, it happened again! We also had a new fuel filter installed last March as well. Why does this happen?
Favorite Features
Front seats are really comfortable. 4 Wheel Drive is great in the snow. I love being up high when I drive. Too bad they stopped making this model. O well, I have 84K miles on my 2003, and hope it will last me for a few more years. Next vehicle will probably be a Ford F150 Extended Cab.
Suggested Improvements
Doesn't matter since they've stopped making this vehicle. Too bad too.
Recommend (9) (0)
Report it
Comments (3) Post a Comment
By podfj
on 03/23/14 18:29 PM (PDT)

Check the fuel pump collission switch on the inside firewal on the passenger side. It might be partially engaged. Climb under the dashboard and push the button anyway. You might not have problems after that! Its in the manual. on page 36 I think.

Report it
By azzureone
on 07/26/12 20:59 PM (PDT)

I had a ford mustang that did the same thing we replaced the fuel pump etc dealer couldnt replicate. I finally solved the problem only use cheveron gasoline!!! I am serious If I used any thing but cheveron gas it would vapor lock and take 5 to 10 min to start. the car only ran on cheveron gas. Try it, it may work for you. I guess its the techroline additive they put in it.

Report it
By lovemytrac
on 05/21/13 09:10 AM (PDT)

Have to agree with previous comment. It is gas sensitive. I ran 85 octane here in Colorado once and had starting issues. It is gas sensitive.

Report it
Post a Comment

You must be signed in to post a comment.

Register

ADVERTISEMENT
Nearby Inventory Zip Code UPDATE
 
ADVERTISEMENT
ADVERTISEMENT