Select a different vehicle  
Recently Viewed
There are no recently viewed vehicles to display

Average Consumer Rating 94 Total Reviews
Write a review

Performance
Comfort
Value
Fun-to-Drive
Interior Design
Exterior Design
Build Quality
Reliability
6 of 6 people found this review helpful
excessive oil consumption
By jjohn22 on
Vehicle
2007 Chevrolet Suburban LT 1500 4dr SUV (5.3L 8cyl 4A)
Review
Around 36000 miles I noticed our suburban started consuming 1 quart of oil per 1000 miles. Over the past 2 years I have had the dealership try various "fixes" but it still consumes oil. This is becoming a trend with the '07 suburban as others are experiencing the same problem. My vehicle will be at the dealership for a week for the next round of exploratory surgery on the engine. Hopefully they can find a fix as I am running out of powertrain warranty in a few months. The first 2 years with this vehicle we had repeated electrical problems with battery discharge. GM found a fix for that.
Favorite Features
We bought this model for our family vehicle because of its generous size and comfort on trips.
Suggested Improvements
Major problem with oil consumption and electrical problems causing repeated battery discharge. To date there has been no GM fix for the oil consumption. It will be back at the dealership next week for the 3rd round of tearing down the engine. For all this effort it would have been more cost effective to just replace the engine. GM customer service is not much help...they call every few days to ask "is it fixed yet?" They act more as customer pacifiers than problem solvers.
Recommend (6) (0)
Report it
Comments (4) Post a Comment
By mwhitaker
on 07/01/11 16:19 PM (PDT)

what was the fix for battery drain problem

Report it
By mwhitaker
on 07/01/11 16:17 PM (PDT)

same problems dealer doing oil consumption test. also had 3-4 battery drain problems 2007 suburban

Report it
By ashli_w2
on 06/05/13 12:50 PM (PDT)

we are having same oil consumption problem, and the battery just died the other day any one have rear displacement problems?

Report it
By buddy77
on 07/03/13 07:42 AM (PDT)

I had the same problem. Have your dealer look at Bulletin J1307 15.30. I had my engine rebuilt because of the oil consumption and my dealer knew why.

Report it
Post a Comment

You must be signed in to post a comment.

Register

ADVERTISEMENT
Nearby Inventory Zip Code UPDATE
 
ADVERTISEMENT
ADVERTISEMENT
Have a question? We're here to help!
Chat*
Chat online with us
Email
Email us at help@edmunds.com
*Available daily 8AM-5PM Pacific