1999 Chevrolet Silverado 1500 5.3L V8 4-speed Automatic Consumer Review - Bought New in 1999
ADVERTISEMENT

1999 Chevrolet Silverado 1500 - Consumer Review

Average Consumer Rating

71 Total Reviews

LT Extended Cab Pickup (5.3L V8 4-speed Automatic)

ADVERTISEMENT
Select a different vehicle  
Recently Viewed
There are no recently viewed vehicles to display
ADVERTISEMENT
Performance
Comfort
Value
Fun-to-Drive
Interior Design
Exterior Design
Build Quality
Reliability
4 of 4 people found this review helpful
Bought New in 1999
By passedu on

Vehicle

1999 Chevrolet Silverado 1500 LT 3dr Extended Cab SB

Review

I purchased this truck new in 1999, trading in a 1997 Monte Carlo. The truck has been reliable and comfortable for over 165,000 miles. Within the last month the gear selector and mileage indicator LED failed. Repair requires replacement of the entire gauge assembly. Early on I had to have the ABS manifold replaced, under warranty. Since then, starter at 158,000, drivers window electric motor at 156,000, and I had the front end rebuilt at 159,000. I replaced the orginal rear shocks within the last two weeks (Jan 11). There was no leakage, but rear end bouce was noticeable.

Favorite Features

I've used this truck for towing, cargo hauling and for use in carrying firewood, rocks and sand. Always performs well. Fuel mileage is excellent at 15mpg local and up to 22mpg on the interstate. Only modifications are a K&N air filter and modified exhaust system. The tow/haul mode is a good feature. I find dropping into 3rd gear from overdrive provides better acceleration at high speed. In heavy traffic, the increase in RPM provides better throttle response in traffic.

Suggested Improvements

Fog lights should not have an override with high beams. An option for an in-bed spare tire mounting location would be good. It would be nice if Chevy had provided for piece part replacement of gauges and LED components, vice having to replace the entire instument gauge module. ($400+ dollars) Rear seat reading lamps would be good.
Recommend (4) (0)
Report it
Comments (1) Post a Comment
By sleipner
on 05/29/13 19:12 PM (PDT)

I know it's a bit late, but the gauge cluster you could have fixed yourself for thirty dollars or less. I had the same issue on mine and all it required was removing the cluster and resaudering two pins of the LED display to the motherboard.

Report it
Post a Comment

You must be signed in to post a comment.

Register

Nearby Inventory Zip Code UPDATE
 
ADVERTISEMENT
ADVERTISEMENT
ADVERTISEMENT
Have a question? We're here to help!
Chat*
Chat online with us
Email
Email us at help@edmunds.com
*Available daily 8AM-5PM Pacific
Phone*
Call us at 855-782-4711
SMS*
Text us at ED411