2007 Audi A4 2.0L 4-cyl. Turbo AWD 6-speed Automatic Consumer Review - Loved this car, until I
ADVERTISEMENT

2007 Audi A4 - Consumer Review

Average Consumer Rating

133 Total Reviews

2.0T quattro Sedan (2.0L 4-cyl. Turbo AWD 6-speed Automatic)

ADVERTISEMENT
Select a different vehicle  
Recently Viewed
There are no recently viewed vehicles to display
ADVERTISEMENT
Performance
Comfort
Value
Fun-to-Drive
Interior Design
Exterior Design
Build Quality
Reliability
1 of 1 people found this review helpful
Loved this car, until I realized it has a serious oil consumption problem which Audi has been dismissing for 2 years.
By a4burnsoil on

Vehicle

2007 Audi A4 2.0T quattro 4dr Sedan AWD (2.0L 4cyl Turbo 6A)

Review

Loved this car, enough that I purchased it off the lease after 3 years. Biggest mistake ever. I have been bringing it for oil consumption problems since Oct 2009 and been more than casually dismissed after wasting a lot of time and worry. Past 3 times I have burned more than a quart of oil after driving only 600-700 miles. Audi keeps giving me the run around (Fletcher Jones Audi Chicago has consistently given me the worst customer service of my life). They keep making me bring it back for oil consumption tests which have been repeatedly performed and telling me there is nothing wrong with it. I am at a loss and have written to Better Business Bureau and the Audi USA customer service.

Favorite Features

Appearance, drive.

Suggested Improvements

Excessive oil consumption is a deal-breaker. Audi customer service has been the worst I have ever dealt with in any consumer arena.
Recommend (1) (0)
Report it
Comments (2) Post a Comment
By pharmgirl
on 02/22/11 18:48 PM (PST)

I bought the A4 for my daughter last summer, certified, preowned so called 400 points of inspection-ha! Less than 10k miles later, have had it in for oil consumption test and vibration while in drive at a stop light. They replaced injectors and cleaned carbon buildup several weeks ago which did not solve vibration issue. 2 days ago oil light came on for the 3rd time in6 months. After driving less than 5 miles a terrible burning smell came from engine, like a gas/oil mix smell. Checked oil dipstick and there was barely a touch of oil on the end. Had car towed to dealer today. Have also been in touch with Audi customer care, I will follow up with my resolution

Report it
By darknessb7
on 08/11/11 12:40 PM (PDT)

I have had the same issues. I am in San Diego Ca. I took my Audi to Mira Mar Audi and they told me it was normal. Then it happend again and they just rebuilt the motor. About 600 miles to the dot it happend again. They just took my car and placed a brand new egine in it. At the time the car had 38k on it and im at 47k not and its been ok. They told me that Audi was doing this to all of the cars that were coming in with this issue. I would really look into it with the dealer.

Report it
Post a Comment

You must be signed in to post a comment.

Register

Nearby Inventory Zip Code UPDATE
 
ADVERTISEMENT
ADVERTISEMENT
ADVERTISEMENT
Have a question? We're here to help!
Chat*
Chat online with us
Email
Email us at help@edmunds.com
*Available daily 8AM-5PM Pacific
Phone*
Call us at 855-782-4711
SMS*
Text us at ED411